1. Comment se connecter au routeur

  2. Comment enregistrer la configuration

  3. Configuration de base

  4. Configurer ssh

  5. Configuration des ports

  6. Mise à jour

  7. Configuration des services syslog, snmp, ntp

  8. Quelques commandes de diagnostique

  9. Configuration du routage statique

  10. Configuration du routage ospf

  11. Configuration du routage intervlan

  12. Configuration des ACLs

  13. Configuration du protocole HSRP

  14. Configuration du protocole DHCP

  15. Introduction routage IPv6





Comment configurer le routage intervlan sur un routeur Cisco?
Il est toujours possible de connecter une interface de routeur à un port d'accès pour chaque vlan. Solution peu pratique car gourmande en port de routeur, de switch et de cablage.
Une autre solution est de connecter l'interface d'un routeur à un port trunk d'un switch et de configurer des sous-interfaces au niveau de l'interface du routeur.
Une troisième solution est l'utilisation d'un commutateur de niveau 3.

Routage intervlan à l'aide de sous-interfaces

Dans l'exemple, il y a deux vlan (le 2 et le 3).L'interface fa 1/0 du routeur est connectée à une interface trunk du switch.
R1(config)#interface fastEthernet 1/0.2
R1(config-subif)#encapsulation dot1Q 2
R1(config-subif)#ip address 192.168.2.1 255.255.255.0
R1(config-subif)#no shut
R1(config-subif)#exit
R1(config)#interface fastEthernet 1/0.3
R1(config-subif)#encapsulation dot1Q 3
R1(config-subif)#ip address 192.168.3.1 255.255.255.0
R1(config-subif)#no shut
R1(config-subif)#end

Commande de vérification sur le routeur

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.2.0/24 is directly connected, FastEthernet1/0.2
C 192.168.3.0/24 is directly connected, FastEthernet1/0.3
R1#

R1#sh run interface fastEthernet 1/0.2
Building configuration...

Current configuration : 96 bytes
!
interface FastEthernet1/0.2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
end

R1#sh run interface fastEthernet 1/0.3
Building configuration...

Current configuration : 96 bytes
!
interface FastEthernet1/0.3
encapsulation dot1Q 3
ip address 192.168.3.1 255.255.255.0
end

R1#

R1#sh int fa1/0.2
FastEthernet1/0.2 is up, line protocol is up
Hardware is i82543 (Livengood), address is ca00.0d38.001c (bia ca00.0d38.001c)
Internet address is 192.168.2.1/24
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 2.
ARP type: ARPA, ARP Timeout 04:00:00
Last clearing of "show interface" counters never
R1#
R1#sh int fa1/0.3
FastEthernet1/0.3 is up, line protocol is up
Hardware is i82543 (Livengood), address is ca00.0d38.001c (bia ca00.0d38.001c)
Internet address is 192.168.3.1/24
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 3.
ARP type: ARPA, ARP Timeout 04:00:00
Last clearing of "show interface" counters never
R1#



Recherche personnalisée