1. Comment se connecter au routeur

  2. Comment enregistrer la configuration

  3. Configuration de base

  4. Configurer ssh

  5. Configuration des ports

  6. Mise à jour

  7. Configuration des services syslog, snmp, ntp

  8. Quelques commandes de diagnostique

  9. Configuration du routage statique

  10. Configuration du routage ospf

  11. Configuration du routage intervlan

  12. Configuration des ACLs

  13. Configuration du protocole HSRP

  14. Configuration du protocole DHCP

  15. Introduction routage IPv6





Pourquoi utiliser HSRP?
Configuration de HSRP

Pourquoi utiliser HSRP?

HSRP (Hot Standby Routing Protocol) est utilisé pour assurer une disponibilité accrue de la passerelle d'un réseau. L'adresse IP de la passerelle est configurée sur deux routeurs différents. Une seule de ces deux interfaces est active. Si l'interface active n'est plus accessible, l'interface passive devient active.

Configuration de HSRP

exemple configuration HSRP

Configuration de R1

R1(config)#int fa0/0
R1(config-if)#ip address 192.168.0.3 255.255.255.0
R1(config-if)#no shut
R1(config-if)#
R1(config-if)#standby 100 ip 192.168.0.1
R1(config-if)#standby 100 preempt
R1(config-if)#end
R1#
R1#sh run int fa0/0
Building configuration...

Current configuration : 145 bytes
!
interface FastEthernet0/0
ip address 192.168.0.3 255.255.255.0
duplex auto
speed auto
standby 100 ip 192.168.0.1
standby 100 preempt
end

R1#

Configuration de R2

R2(config)#int fa0/0
R2(config-if)#ip address 192.168.0.2 255.255.255.0
R2(config-if)#standby 100 ip 192.168.0.1
R2(config-if)#standby 100 priority 110
R2(config-if)#standby 100 preempt
R2(config-if)#end
R2#
R2#sh run int fa0/0
Building configuration...

Current configuration : 171 bytes
!
interface FastEthernet0/0
ip address 192.168.0.2 255.255.255.0
duplex auto
speed auto
standby 100 ip 192.168.0.1
standby 100 priority 110
standby 100 preempt
end

Vérification

Dans la sortie de commande suivante, le routeur actif est R2 (conformément à la priorité donnée dans la configuration des interfaces).
R1#show standby fastEthernet 0/0
FastEthernet0/0 - Group 100
State is Standby
4 state changes, last state change 00:00:51
Virtual IP address is 192.168.0.1
Active virtual MAC address is 0000.0c07.ac64
Local virtual MAC address is 0000.0c07.ac64 (default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.712 secs
Preemption enabled
Active router is 192.168.0.2, priority 110 (expires in 9.696 sec)
Standby router is local
Priority 100 (default 100)
IP redundancy name is "hsrp-Fa0/0-100" (default)
R1#

R2#show standby fastEthernet 0/0
FastEthernet0/0 - Group 100
State is Active
2 state changes, last state change 00:05:50
Virtual IP address is 192.168.0.1
Active virtual MAC address is 0000.0c07.ac64
Local virtual MAC address is 0000.0c07.ac64 (default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.144 secs
Preemption enabled
Active router is local
Standby router is 192.168.0.3, priority 100 (expires in 9.688 sec)
Priority 110 (configured 110)
IP redundancy name is "hsrp-Fa0/0-100" (default)
R2#



Recherche personnalisée